running smle project

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

running smle project

Nam Giang
Hi there,

I've just been aware of the GSoC 2016 today, but better late than never :).

Anyway, I'm very interested in smle. I tried to run it but it seems Angular doesn't kick in. There is only one time that I've seen it works, but then things get screwed. It keeps showing something like this:
Inline image 1

I'm not sure it's something to do with NPM, Node or Typescript or any other dependencies because as I tried to make it work, I tried with different versions of Typescript and es7-reflect-metadata. It was totally a white blank at the after-clone run and showed this after I include import 'reflect-metadata'; in main.ts.

I've tried with:
$ npm install
$ npm run build
$ npm run server

or run build:prod, run server:prod

So for the challenge, making it run was my first challenge as I am not familiar with TypeScript (yet). However, I found that the Adress component has been implemented already in editor/components/iso/gmd/AddressComponent.ts and .html


I've put up a project proposal anyway in GSoC site, hoping to get a helping hand on this soon :)

Thanks,

Wait, my name is Nam Giang, a PhD student at the University of British Columbia, Vancouver, Canada.

Cheers.

_______________________________________________
GSoC mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/gsoc
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines
Loading...